Skip to content
68

Awesome Real Time Communications

:satellite: A curated list of awesome Real Time Communications resources

497 stars48 forks94 entriesLast push May 18, 2026 (4 months ago)License CC0-1.0

This page lists names, links and short descriptions. The original list on GitHub is the source and belongs to its authors.

Server Software >General Purpose

FreeSWITCH

Open source multi-protocol, cross-platform and software switch.

Asterisk

PBX framework supporting multiple protocols and platforms.

Server Software >SIP Servers

Kamailio

Open source SIP server widely deployed by carriers and providers. Formerly known as OpenSER.

In 2 lists

OpenSIPS

Open source SIP server, tracing its roots in OpenSER (presently Kamailio).

Routr

Lightweight SIP proxy, location server, and registrar written in Node.js.

In 2 lists

Sippy B2BUA

Back-to-back user agent server written in Python.

Flexisip

SIP server suite comprising proxy, presence and group chat functions.

Server Software >Media Servers

Janus

Lightweight open source, general purpose, WebRTC gateway.

In 2 lists

LiveKit

Open-source WebRTC infrastructure for building scalable real-time audio and video applications.

RTPProxy

General purpose high performance RTP proxy.

RTP:Engine

RTP and UDP based media traffic proxy, usable as a kernel module.

mediasoup

Specialized WebRTC conferencing system.

In 2 lists

SEMS

Open source media and application server for SIP based VoIP services.

Jitsi

A collection of RTC open source projects, with a focus on conferencing software.

Server Software >STUN/TURN

coturn

Fully featured TURN/STUN server supporting multiple platforms.

In 4 lists

eturnal

Modern and scalable STUN/TURN server written in Erlang.

natcheck

NAT type diagnosis CLI. Probes STUN servers, classifies mapping behaviour per RFC 5780, and reports a WebRTC direct-P2P forecast.

STUNTMAN

RFC compliant open source STUN implementation.

Server Software >Monitoring

sngrep

Terminal based SIP flow viewer.

In 2 lists

sipgrep

Console tool for sniffing, capturing and exploring SIP traffic.

rtpbreak

Detect, reconstruct and analyze RTP sessions.

HOMER

Multi-protocol capturing and monitoring framework for RTC.

In 3 lists

WebRTC Troubleshooter

Self-hosted one stop client-side WebRTC troubleshooter.

Trickle ICE

Exposes client-side NAT traversal debug data.

SIP3

VoIP & RTC traffic monitoring and analysis platform.

In 2 lists

Server Software >Testing

SIPp

Traffic generator for the SIP protocol.

SIPVicious

Suite of security tools that can be used to audit SIP based VoIP systems.

In 2 lists

sipsak

SIP stress and diagnostics utility.

sipexer

Modern and flexible SIP command line tool.

Server Software >Deployment

slimswitch

Tooling for creating lean secure FreeSWITCH Docker images.

Server Software >Web/API Interfaces

Eqivo

Open source programmable-voice/telephony API platform.

Kazoo

Carrier-grade VoIP API platform using FreeSWITCH and Kamailio.

FusionPBX

Multitenant system built on top of FreeSWITCH.

In 2 lists

FreePBX

Web Manager for Asterisk.

In 2 lists

Fonoster

Telecommunication stack built with Node.js.

In 2 lists

Wazo

VoIP API platform built on top of Asterisk, Kamailio and RTPEngine.

In 2 lists

jambonz

Open source CPaaS built for communications service providers.

IVOZ Provider

Multitenant solution for VoIP telephony providers.

Sayna

Real-time speech infrastructure for voice AI with WebSocket streaming, SIP telephony and pluggable STT/TTS providers.

In 2 lists

Server Software >Billing

CGRateS

Carrier grade open source billing/rating server.

A2Billing

Billing system for Asterisk for multiple applications.

PyFreeBilling

Wholesale billing platform for Kamailio and FreeSWITCH.

Developer Resources >Tutorials

Official Website

Entry level WebRTC resources.

In 3 lists

Getting Started With WebRTC

WebRTC tutorial by HTML5 Rocks.

WebRTC Samples

Collection of samples demonstrating various parts of the WebRTC APIs.

WebRTC Experiments

Comprehensive list of samples by Muaz Khan.

Interactive Codelab

30 minutes step by step live tutorial by Google.

Developer Resources >JavaScript Libraries

drachtio

Node.js SIP server framework.

adapter.js

JavaScript shim for abstracting WebRTC spec changes and inconsistencies.

JsSIP

Lightweight open source JavaScript SIP library.

sipML5

Open source JavaScript SIP client with WebRTC media stack.

simple-peer

WebRTC video, voice, and data channels abstraction for Node.js and the browser.

In 4 lists

Netflux

Isomorphic JavaScript peer to peer transport API for client and server.

In 2 lists

PeerJS

Data and media peer-to-peer connection API implemented over WebRTC.

In 2 lists

Socio

A WebSocket Real-Time Communication (RTC) API framework. Realtime Front-end, Back-end reactivity.

Developer Resources >C/C++ Libraries

libre

Portable SIP Stack along with companion libraries for media handling, STUN/TURN and a modular user agent.

PJSIP

Multi-protocol RTC library written in C.

In 2 lists

eXosip

eXtended osip is a mature C library for abstracting the SIP protocol.

libdatachannel

Standalone WebRTC DataChannels C++ implementation.

In 3 lists

icey

C++20 WebRTC media runtime with FFmpeg pipeline, Symple signalling, and RFC 5766 TURN.

In 3 lists

libSRTP

Secure Real-time Transport Protocol (SRTP) library for C.

usrsctp

Portable Stream Control Transmission Protocol (SCTP) user-land stack.

rawrtc

WebRTC and ORTC library with a small footprint.

OSS Core

General purpose C++ library for Real Time Communications.

Open WebRTC Toolkit

WebRTC development toolkit with bindings for multiple platforms.

Sofia-SIP

Open source SIP library used by FreeSWITCH.

Developer Resources >Go Libraries

Pion

Extensive software stack for WebRTC written in Go.

gossip

SIP stack for stateful user agents written in Go.

siprocket

Fast SIP and SDP packet parser.

In 2 lists

go-diameter

RFC compliant Diameter protocol library.

Developer Resources >PHP Libraries

RTCKit/SIP

RFC 3261 compliant SIP parsing and rendering library for PHP 7.4+.

Developer Resources >Python Libraries

aiortc

WebRTC and ORTC implementation for Python using asyncio.

In 3 lists

Katari

SIP stack application framework.

peerjs-python

Python port of the PeerJS peer-to-peer connection library.

Developer Resources >Erlang Libraries

NkSIP

Extendable SIP server framework.

ersip

Library comprising building blocks for SIP applications.

Developer Resources >Rust Libraries

libsip

SIP implementation, with a focus towards softphone clients.

sipcore

Rust framework for creating SIP applications.

rtcrs/webrtc

WebRTC stack, supporting SDP, RTP, RTCP and SRTP.

Developer Resources >Dart Libraries

dart-sip-ua

Dart-lang port of JsSIP, capable of SIP over WebSocket.

Blogs

BlogGeekMe

Blog by Tsahi Levent-Levi with a strong focus on WebRTC.

SIP Adventures

Unified communications blog by Andrew Prokop.

WebRTCHacks

WebRTC blog by independent technologists.

Discussion

FreeSWITCH Slack

Join #freeswitch and #freeswitch-dev for user and developer support.

discuss-webrtc

Developer oriented Google Group for WebRTC discussions.

In 2 lists

Events

ClueCon

Annual conference held in Chicago for telecommunications developers. Birthplace of FreeSWITCH.

Kamailio World

Berlin hosted annual event focused on Kamailio as well as VoIP, WebRTC, IMS, VoLTE and more.

AstriCon

Asterisk focus event held every year across the US.

CommCon

Annual conference held in the UK focused on telecommunications in general and WebRTC in particular.

OpenSIPS Summit

Meeting place for the OpenSIPS community.

Kranky Geek

AI and RTC event in San Francisco.

FOSDEM

Free event for software developers, with a RTC component, held every year in Europe.

In 4 lists

JanusCon

JanusCon is a live event for Janus and RTC implementers.

TADHack

Global hackathon focused on programmable communications.

See category
87

Awesome Network Automation

networktocode/awesome-network-automation

Curated Awesome list about Network Automation

Fresh★ 2.9k334 entriesPushed yesterday
80

Awesome Network Analysis

briatte/awesome-network-analysis

A curated list of awesome network analysis resources.

Fresh★ 4.1k717 entriesPushed 1 month ago
72

Awesome TensorFlow

jtoy/awesome-tensorflow

TensorFlow - A curated list of dedicated resources http://tensorflow.org

Slow★ 18k160 entriesPushed 7 months ago
71

Awesome Networking

facyber/awesome-networking

A collection of awesome networking courses, books, tutorials and other resources

Active★ 1.3k85 entriesPushed 4 months ago
61

Awesome SNMP

eozer/awesome-snmp

A curated list of awesome SNMP libraries, tools, and other resources.

Slow★ 193141 entriesPushed 6 months ago
60

Awesome Pcaptools

caesar0301/awesome-pcaptools

A collection of tools developed by other researchers in the Computer Science area to process network traces. All the right reserved for the original authors.

Slow★ 3.4k106 entriesPushed 1 year ago